Etiketler

Youtube Kanalıma Abone Olunuz

28 Eylül 2019 Cumartesi

EXCEL: DÜŞEYARA ile soldan bilgi bulma

Excelde DÜŞEYARA formülü tablodaki veya satır aralığındaki öğeleri bulmamız gerektiğinde kullanılır.

En basit haliyle DÜŞEYARA kullanımı:

= DÜŞEYARA (aramak istediğiniz; aranacak tablo; tablodaki sütun numarası; 1/DOĞRU veya 0/YANLIŞ)

4. parametrede;
1/DOĞRU: yaklaşık olarak,
0/YANLIŞ: tam bir eşleşme yapar.

Örnek:
Aşağıdaki öğrenci tablosundan okul numarasına göre arama yapılıp bulunan öğrencinin bilgilerini elde edilir.


I3 hücresinde Adı soyadı bilgisini elde etmek için
=DÜŞEYARA($I$2;$C$2:$F$11;2;)
formülü kullanıldı. Formülde I2 yerine $I$2, C2:F11 yerine $C$2:$F$11 kullanıldı bu işlem, formülü kopyaladığımızda hücre adresinin değişmemesi içindi.
4. parametre boş bırakıldı. Bu, 0 değerini girmekle aynıdır. Tam eşleşme yaparak arar.

Diğer örnekler ile Baba adı ve Doğum yeri bilgileri elde edilmiştir.
=DÜŞEYARA($I$2;$C$2:$F$11;3;)
=DÜŞEYARA($I$2;$C$2:$F$11;4;)

Buraya kadar güzel ancak okul no'suna göre ya da öğrenci adına göre arama yapıp sınıfı bilgisini elde etmeye çalışırsak DÜŞEYARA formülü buna izin vermiyor. Çünkü aradığımız, sütunun sağ tarafından bilgi alabiliyoruz.

Tabloda soldan bilgi elde etmek istediğimiz bir durum olursa ne yapabiliriz?

Bunun için birkaç yöntem var.
En basit kullanımı aşağıdaki gibidir.


DÜŞEYARA formülündeki ikinci parametreye tabloyu direkt olarak değilde ELEMAN ile dolaylı olarak aktarılıyor.

=DÜŞEYARA(I2;ELEMAN({1;2};D2:D11;C2:C11);2;0)

ELEMAN formülü tabloyu bellekte yeniden oluşturuyor formüldeki {1;2} ile 2 sütunlu bir tablo olacağını belirtiyor.
1. sütunu olarak D2:D11 (Adı soyadı),
2. sütunu olarak solundaki C2:C11 (No) seçiliyor.

Böylece Adı soyadı ve No'dan oluşan yeni tablo oluşuyor.
DÜŞEYARA formülü ile oluşan bu yeni tabloda arama yapıp sonuç elde ediyoruz.
Esasında yine DÜŞEYARA ile aradığımızın sağından bilgi elde etmiş oluyoruz.

Sınıfı bilgisini elde etmek için ELEMAN ile bir tablo oluşturuyoruz 2 sütunlu.
1. sütun D2:D11 (Adı soyadı)
2. sütun B2:B11 (Sınıfı)

Oluşan bu tablodan DÜŞEYARA ile Adı Soyadını arayıp Sınıfı bilgisini elde ediyoruz.

=DÜŞEYARA(I2;ELEMAN({1;2};D2:D11;B2:B11);2;0)

Hiç yorum yok:

Yorum Gönder